PAT 1035.Password

题目

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line “There are N accounts and no account is modified” where N is the total number of accounts. However, if N is one, you must print “There is 1 account and no account is modified” instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

我的解决方案

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
#include <iostream>
#include <string>
#include <vector>

//解题思路:
//用string保存密码,遍历替换,若有替换的字符,
//则将该账户存入vector中,最后检查vector.size()
//不为0则打印之,并打印vector中的元素
//否则输出提示信息

using namespace std;

class Account {
public:
void input()
{ cin >> username >> password; }

void show() const
{ cout << username << " " << password; }

bool modified()
{
bool changed = false;

for (auto &x : password) {
switch (x) {
case '1' : x = '@'; changed = true; break;
case '0' : x = '%'; changed = true; break;
case 'l' : x = 'L'; changed = true; break;
case 'O' : x = 'o'; changed = true; break;
}
}

return changed;
}
private:
string username;
string password;
};

int main()
{
int n;
vector<Account> result;

cin >> n;

for (int i = 0; i < n; ++i) {
Account account;

account.input();
if (account.modified()) {
result.push_back(std::move(account));
}
}

if (result.size()) {
cout << result.size() << endl;
for (const auto &x : result) {
x.show();
cout << endl;
}
}
else {
cout << "There " << (n == 1 ? "is" : "are") << " " << n
<< " " << (n == 1 ? "account" : "accounts")
<< " and no account is modified" << endl;
}

return 0;
}
Author: sphc
Link: https://jkuvw.xyz/archives/d85e57c2/
Copyright Notice: All articles in this blog are licensed under CC BY-NC-SA 4.0 unless stating additionally.
微信打赏
支付宝打赏